Yhoko/devYhokos Entwicklertagebuch

Onwaaaard!

24. Juli 2013 von Yhoko
Die letzten Tage hing eine düstere Wolke über dem Yhoko.com Hauptquartier – nein, leider keine echte sondern nur eine sprichwörtliche; eigentlich schien die Sonne und es war viel zu warm. Aber das Wetter nimmt auf keinen Rücksicht, denn ich behaupte vorsichtig, dass es am aktuellen Debakel schuld ist. Aber nicht nur.

Die Dunkelheit begann am Freitag, als meine Wii plötzlich den Geist aufgab. Um genau zu sein wollte sie keine CDs mehr lesen und auch nur sehr mühsam wieder aussprucken. Das Wochenende war aber ohnehin als Basteltage gekennzeichnet, mein Game-PC lief nicht mehr und auch ein alter Freund kam zu Besuch und brachte seinen Rechner für eine Neuinstallation mit. Also halb so wild. Gebastelt wurde dann auch – nach 4 Stunden Schräubchendrehen konnten wir zumindest Wii Sports einlegen; was anderes spiele ich ohnehin nicht (und hätten am liebsten einen von Nintendo erschossen – dämliche Dreiecksschrauben). Die restliche Nacht auf den Sonntag verbrachte ich also damit, meinen Game-PC wieder flott zu kriegen. Anfangs sah es bitter aus, doch offenbar war ich so schlau erst kürzlich ein Backup zu ziehen, welches dann freudigerweise auftauchte, und so war zumindest das bald wieder repariert. Endlich wieder Skyrim! Parallel dazu brachte ich Selays Rechner wieder in Ordnung, wobei Ubuntu sich nicht so recht mit Windows 7 vertragen wollte. Der Bootloader machte Probleme; also nichts tragisches. Am frühen Nachmittag gönnte ich mir eine kleine Mütze Schlaf, dann verschwand Selay wieder nach Hause.

Dann kam die Überraschung: Alles lief irgendwie ... lahm. Kurzer Blick auf den Server; das aktuelle Backup wurde gerade zu Jeromy übertragen. Aber wieso brauchte das 2'000% Prozessorleistung? Wie sich herausstellte war es eine Hardwarebremse; die Temp-Festplatte hatte ihren Geist aufgegeben. Das ist die mit den Minecraft-Welten, noch nicht sortierten Downloads und Daten von meinen früheren Rechnern. Die wichtigen Sachen daraus waren zwar längst woanders, aber nicht zu wissen, was alles verloren gegangen war (insbesondere die Downloads) war schon ärgerlich. Also versuchte ich, die Platte wieder zum Laufen zu kriegen, indem ich sie aus dem Server nahm und bei mir einbaute.

Symptome: Festplatte startet, beschleunigt, soweit okay, aber dann klackt der Lesekopf nur ein paar Mal, ehe er aufgibt und sich schlafen legt. Auch das BIOS wollte kein HDD erkennen. Mist. Und dann gings doch plötzlich mal, der PC startete fröhlich und dann – Fehlanzeige, keine Partitionen. Daten weg? Entrüstung. Dann ein Hoffnungsschimmer: die ursprüngliche Temp-Platte kam damals aus meinem Rechner und war mit NTFS formatiert, doch irgendwann wurde sie aus Platzgründen ausgetauscht – und dabei womöglich mit ext3 (Linux) formatiert. Womöglich war die Partition also... ja! Noch vorhanden.
Unter Linux zeigte sich dann dasselbe Bild - meist wurde die Platte bereits vom BIOS nicht erkannt, und wenn doch, nicht eingebunden, und wenn doch waren die Daten nicht lesbar. Meine Ansprüche beschränkten sich bereits darauf, eine Liste der Downloads aus dem Dateisystem zu ziehen, aber manchmal waren die Ordner da, manchmal nicht.

Diese Symptome deuteten auf einen festhängenden Lesekopf hin und hier kommen wir wieder zum Wetter zurück. Es war wirklich warm die letzten Tage und als ich die defekte Festplatte aus dem Gehäuse zog, hätte ich mir fast die Finger verbrannt. Übrigens trotz des Lüfters vor den Server-Festplatten. Womöglich, dachte ich mir, hatte sich einfach nur das Metall ob der mutmasslichen Überhitzung ein wenig verformt.

Mein Lösungsansatz bestand anschliessend daraus, die Festplatte auf -18° zu kühlen und es dann erneut zu versuchen. Diesen Tipp hatte ich im Internet gefunden und für plausibel befunden. Es hiess auch, dass dies eine einmalige, letzte Chance sei, weil die Platte danach zweifellos im Eimer wäre. Mehr als die Dateiliste wollte ich ja aber auch nicht haben. Gesagt, getan, wurde sie erstmal mit Kühlpacks versehen wieder in Betrieb genommen. Und siehe da: Sie startete! Leider meinte das BIOS aber, dass die neue IDE-Festplatte (alle anderen waren SATA) die Bootpartition sei und meldete einen Fehler. Kurzer Neustart um das im BIOS zu berichtigen, und dann wieder Entrüstung – sie wurde nicht mehr erkannt, das bekannte Klacken trat wieder auf. Also nichts mehr zu retten. Oder doch?

Mit etwas Hartnäckigkeit und Experimentierfreude versuchte ich nochmal, die Platte tiefgefroren zu betreiben, und nach ein paar Neustarts kam ich auch tatsächlich an die gewünschte Dateiliste heran – und sah dabei, dass auch einige Downloads dabei waren, die ich unmöglich wieder im Internet finden würde. Ein kleines Textfile mit YouTube-Links konnte ich immerhin kopieren - und damit stand der Beweis, dass die Daten noch vorhanden waren (denn jenes Textfile ergab oft einen I/O Fehler beim öffnen, und dann klappte es wieder einwandfrei). Schnell war klar, dass die Festplatte sich einfach zu schnell aufwärmte (von innen). Das Experiment gipfelte also darin, dass ich sie mit langen IDE- und Stromkabeln innerhalb des Tiefgefrierers bei -18°C betrieb. Mit Erfolg!

...oder zumindest teilweise. Ich konnte die Festplatte wesentlich länger betrachten und die meisten Verzeichnisse öffnen, aber um wirklich etwas zu kopieren war die Zeit zu knapp. Immerhin, aber dennoch – mit einem Teilerfolg wollte ich mich jetzt nicht mehr zufriedengeben. Mittlerweile war es Dienstag und die Festplatte hatte schon gefühlte 100 Neustarts mitgemacht. Mir war bewusst, dass sie jederzeit komplett den Geist aufgeben konnte, aber ich hatte auch nichts ausser Zeit zu verlieren. Also versuchte ich es mehrmals mit Einfrieren, drehte sie mal auf den Kopf oder auf die Seite (man weiss nie ob die Gravitation auch ein wenig hilft), verhinderte Vibrationen, drückte drauf... Es half alles nichts, obwohl sie manchmal tatsächlich wieder startete. Schliesslich kam mir die Idee, dass durch eine Erwärmung das Material erneut verformt würde... ausserdem würde die ständige Vibration womögliche Blockaden vielleicht überwinden. Also liess ich sie einige Stunden bei Zimmertemperatur in Betrieb und versuchte gelegentlich, etwas zu kopieren.

Es klappte! Ich konnte einzelne kleine Dateien kopieren, nur einige Verzeichnisse konnten gar nicht erst gelesen werden. Oft gab es auch beim Kopieren Lesefehler, aber nach mehrfacher Wiederholung klappte es und die Dateien waren tatsächlich korrekt mit Inhalt gefüllt. Irgendwann erreichte die Platte angenehme +40°C und etwa ab da passierte es: Es ging wieder! Alles! In grosser Euphorie kopierte ich die wichtigsten Dateien, ging dann weiter zu den seltenen Downloads und als auch da keine Probleme auftraten, kopierte ich kurzerhand die gesamte Festplatte auf eine andere. Ein unglaublicher Erfolg!

Ich weiss nicht, ob sie jetzt noch funktionieren würde, aber meine Bitte nach einem "letzten Mal" hat sie schonmal tadellos erfüllt. Brave Festplatte. Mittlerweile war es Mittwoch und der gestern bestellte Ersatz kam bereits per Post an, so dass ich die Daten bereits wieder auf den Server kopieren konnte. Ironie des Schicksals: Als die Vermutung nahe lag, nichts mehr retten zu können, startete ich einen Transfer der Minecraft-Welten von Jeromys Backup. Er war in derselben Minute abgeschlossen, in der ich die Welten von der defekten HD zurücktransferiert hatte. Aber ich will mich nicht beschweren; die Originaldaten sind wieder da und das Backup hätte allenfalls einwandfrei funktioniert. Und auch das Wetter meint es heute nochmal wolkig gut, bevor die Sonne in den nächsten Tagen laut Wetterbericht so richtig aufdreht.

Nach diesen zeitweise von knisternder Spannung erfüllten Tagen kehre ich nun also wieder zu Endyr zurück und setze die Entwicklung fort. [YouTube] Onwaaard!
Thema: Endyr


Kommentar schreiben

Name:
E-Mail:
Beitragstext: